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 Troubleshoot FTP upload problems (GoLive 6.x, CS)

Issue

You can't upload site files or folders to FTP server using Adobe 
GoLive. Files aren't uploaded to the server or you receive one of 
the following errors: an

--!"FTP Error: 530"

--!"FTP Error 550: Unexpected disconnect"

Solutions

Do one or more of the following:

1.!Install GoLive 6.0.1.

If you use GoLive 6.0, install the GoLive 6.0.1 update. You can 
download the GoLive 6.0.1 update from the Adobe Web site at 

.www.adobe.com/support/downloads/main.html 

2.!Verify that your Internet or network connection is active.

In a Web browser, open a Web site, such as www.adobe.com, to 
verify that the browser connection to the Internet is active and isn't 
being used by another application. If the browser returns a 
message stating that the connection is down, try to reconnect. If 
you still can't connect to the Internet, check the modem and 
modem cable, or check your PPP (Point-to-Point Protocol), MacTCP 
(Transmission Control Protocol), or OpenTransport settings (Mac 
OS), or your TCP/IP settings (Windows). If you are connected to a 
network, verify that the network connection is active. If you can't 
connect to the Internet or the network, contact your Internet 
Service Provider (ISP) or your system administrator.

3.!Change the port number for your site's publish server to 
"21."

Port "21" is the default port for FTP; however, you may want to 
check with the ISP to determine the correct port setting.

To change the port number for a site's publish server in GoLive:

1. Load the site file in GoLive.

2.!Choose Edit > Servers.

3.!In the Edit Publish Server dialog box (GoLive CS) or the 
Available Servers dialog box (GoLive 6.x), select the server that is 
assigned to your current site.

4.!Type after the server name, with no spaces. For example, 
type 

:21
ftp://ftp.netscape.com:21

5. Click OK.

4.!Use Passive mode to upload files.

1. Load the site file in GoLive.

2.!Choose Edit > Servers.

3.!Select the server you want to modify.

4.!Do one of the following:

--!In GoLive CS, select Use Passive Mode.

-- In GoLive 6.x, click Advanced, and then select Use Passive Mode 
in the Advanced options.

5.!Use an FTP proxy, if necessary.
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Use an FTP proxy if the ISP or network uses a proxy server, and 
only if necessary. Contact your network administrator or ISP to 
determine whether you need to use a proxy server.

To turn the FTP Proxy setting on or off:

1.!Choose Edit > Preferences (Windows) or GoLive > Preferences 
(Mac OS).

2.!Select the Internet icon (GoLive CS) or the Network icon (GoLive 
6.x) in the left panel.

3.!Select or deselect Use FTP Proxy. (If you use an FTP Proxy, you 
need to type a host name and port number in the Host and Port text 
fields. Contact the network administrator or ISP to determine what 
those settings are.)

4. Click OK.

6.!Use a third-party FTP utility or browser to verify the FTP 
connection.

Connect to the FTP server using a third-party FTP utility (for 
example, Dartmouth Fetch or WS_FTP) or a browser to verify that 
the FTP server is accepting connections and permitting uploads. If 
you use a browser, enter the URL in the following format:

ftp://username:password@ftp.hostname.com/path_to_your_folder/

If the server accepts connections and permits uploads, you can see 
a listing of the folders available to you on the server.

.7. Disable the Windows XP firewall (Windows XP only)

Refer to the documentation included with Windows for more 
information about firewalls.

8.!Delete the ftpAliassettings.xml file.

Delete the ftpAliassettings.xml file for the site returning the error. 
The file is located in the web-settings folder in the site project 
folder.

You'll need to reenter FTP server information for the site 
after deleting the ftpAliassettings.xml file.
Note:

9.!Upload the site at off times.

Upload the site early in the morning or late at night, when Internet 
usage is usually lighter. 

10.!Verify that the site's FTP uploading preferences contain 
valid entries

Verify that the site's FTP uploading preferences contain valid entries 
for the FTP server, directory, user name, and password. 

To edit a site's FTP uploading preferences: 

1.!Load the site file in GoLive.

2. Choose Site > Settings.

3.!Click the Publish Server icon (GoLive CS) or the FTP & WebDAV 
Server icon (GoLive 6.x) in the left panel.

4. Do one of the following:

--!In GoLive CS, click Add, and then click New in the Select Publish 
Server dialog box.

--!In GoLive 6.x, choose Edit Server from the FTP Server menu, 
and then select the New item icon.

5.!In the following fields, enter the FTP server name, the path to 
your directory, your user name, and your password, as specified by 
the ISP:

--!Server

The server's hostname may be in WWW format (for example, 
www2.earthlink.net), FTP format (for example, ftp.mindspring.com), 
or IP format (for example, 206.251.11.2). (An FTP hostname is 
typically different from an HTTP hostname.) 
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--!Directory

The directory path should refer to an actual folder on the Web 
server. The ISP can confirm the path for you. If the folder to which 
you initially connect when you log in to the Web server is different 
from the folder in which you store files, click Browse, navigate to 
the folder in which you store files, and then click OK. 

You can also manually enter the relative path from the connection 
folder to the storage folder (for example, "~user," "public_html," 
"users/username/"). Use forward slashes ( / ) to indicate a change 
of folder hierarchy. Do not precede the pathname with a forward 
slash ( / ) unless you're entering the full absolute path on the Web 
server from the connection folder to the storage folder (for 
example, /home/user/public_html/). 

If your user name and password automatically log you into 
your public HTML folder (where your Web pages are stored), leave 
the Directory field blank. If this field contains incorrect information, 
new folders will be created in your folder on the Web server. Your 
files may upload successfully but not to the correct location, so you 
won't be able to see them.

Note:

--!User name

The ISP specifies your user name. 

--!Password

The ISP specifies the password for your user name.

11.!Name all files and folders in the site using only 
alphanumeric characters, underscores, or hyphens.

GoLive cannot upload files or folders containing HTML-reserved 
characters, such as the forward slash. 

Don't begin a folder name with a tilde character (for example, 
"~images"). UNIX servers use the tilde character as a shortcut to 
change from the original folder to the home folder of the user 
whose name follows the tilde, and return an "access denied" or 
"user unknown" error if they can't find that folder.

12.!Make sure that you have the necessary Web server 
privileges.

Check with the ISP to make sure that you have read, write, and 
delete privileges to all the files, folders, and subfolders inside your 
folder on the Web server.

After you can upload files to your Web site, you can change 
access privileges for files, folders and subfolders in the site using 
the FTP Inspector in GoLive. To change access privileges, be sure 
that the Inspector is visible, choose Window > Inspector or View > 
Inspector (GoLive 4.x for Windows only), and then select a file or 
folder in the FTP tab of the Site window. Select read, write, or 
execute rights for Owner, Group, or Others in the FTP File Inspector 
or the FTP Folder Inspector. Check with the ISP to see how 
privileges should be set for your site.

Note: 

13.!Reset preferences to default settings.

Reset the preferences to the default settings by renaming the 
preferences file, causing GoLive to re-create it. Then reenter the 
FTP server information and retest the connection.

To re-create the GoLive preferences file:

1.!Quit GoLive.

2. Open one of the following folders:

-- Windows XP or 2000: Documents And Settings/ /
Application Data/Adobe/Adobe GoLive

[user profile]

-- Windows 98: Windows/Application Data/Adobe/Adobe GoLive 

-- Mac OS X: Users/ / Library/ Preferences [user name]

-- Mac OS 9.x: System Folder/ Preferences 

3.!Rename the preferences file. For example, add "old" to the end 
of the filename, before the file extension.
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--!GoLive CS (Windows): Adobe GoLive 7.prf

--!GoLive CS (Mac OS): Adobe GoLive 7 Prefs

-- GoLive 6.x (Windows): Adobe GoLive 6.prf

-- GoLive 6.x (Mac OS): Adobe GoLive 6.0 Prefs

4. Start GoLive. GoLive creates a new preferences file.

Deleting the preferences file removes all your custom 
preferences, settings, and server setups from GoLive. Renaming 
the preferences file allows you to restore your old preferences 
later, if necessary.

Note:

If the problem continues, the preferences file is not the cause. To 
restore previous settings, delete the new preferences file, and 
restore the original name of the previous preferences file.

14.!Use a third-party FTP utility (for example, Fetch or 
WS_FTP) to upload files.

If you can upload files using an FTP utility, but not GoLive, contact 
Adobe Technical Support.

Background information

GoLive lets you upload files to an FTP server that has an active 
Internet connection. In Mac OS, FTP servers can use MacTCP, PPP, 
OpenTransport TCP/IP, or OpenTransport/PPP protocol to establish 
connections to the Internet. You can configure the protocol in the 
MacTCP or TCP/IP control panel.

FTP connections can fail if one or more of the following conditions 
occur:

--!computer hasn't connected to the server within the allotted time-
out period (usually specified in the MacTCP or TCP/IP control panel).
The

--!The connection to the Internet is bad or terminated.

--!There is a problem with the modem or modem cable.

--!There is a network problem.

--!The FTP server is down or not accepting connections.

--!Your permissions are not set properly in your upload folder.

--!You have specified an incorrect port (the port you'll connect to on 
the Web server).

GoLive CS and 6.0.1 fix the following FTP issues in GoLive 6.0:

--!If the server connection fails, GoLive CS and 6.0.1 try to connect 
a second time to complete the upload or download process.

--!GoLive CS and 6.0.1 check if the server is Novell (which doesn't 
accept the "LIST -a" command to display hidden files), and if so, 
use the "LIST" command instead.

--!GoLive CS and 6.0.1 allow you to drag files from a mounted 
Workgroup site into the GoLive FTP browser, even if those files 
aren't available locally.

--!When uploading from a Windows computer to a UNIX server, 
GoLive CS and 6.0.1 retain line breaks for files that have Mac OS 
line endings.

GoLive may also be unable to upload files if the Internet is very 
busy. If GoLive can't upload files to an FTP server, you may have to 
use a third-party FTP utility.

GoLive preferences must contain a valid FTP server name, 
directory, user name, and password (which you can get from the 
ISP) before it can upload files. GoLive can use passive mode to 
upload files. In passive mode, the client establishes data 
connections, whereas in active mode, the server establishes data 
connections.

You need to name files and folders to be compatible with the Web 
server or the FTP server to which you upload files. For the greatest 
compatibility, use alphanumeric, eight-character, single-word 
filenames with three-character extensions (for example, 
Document.htm). Make sure to use the correct filename extension 
(for example, .htm or .html for Web page documents; .gif, .jpeg, or 
.jpg for graphics files). Don't use forward slashes, tildes, or spaces 
in file or folder names. If you must use more than one word when 
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you name files, separate the words with an underscore ( _ ) or a 
hyphen ( - ) rather than a space.

Related Documents

323413 How to Configure GoLive to Upload to or Download from AOL

322994 Overview of the FTP Upload Options in CyberStudio and 
GoLive

323529 Unable to Upload Files to a Web Server Using SOCKS 
Gateway With CyberStudio or GoLive
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